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INTRODUCTIE 

Ontsluiten en presenteren van PDOK datasets met OpenCities Map/Bentley Map. 

Gebruikte software: 

 OpenCities Map Enterprise Connect Edition Update 3 (voorheen Bentley Map Enterprise CE) 

 Noot: Bentley Map v8i en OpenCities Map Connect Edition kan ook gebruikt worden. 

 PDOK tools en interface, zijn beschikbaar op de Bentley Communities. 
(https://communities.bentley.com/communities/user_communities/bentley_general_nl/b/webl
og/posts/pdok-wfs-brk-in-dgn-file) 

DATA SETS 

De folder C:/tmc/ bevat de verschillende bestanden en folders die met deze workshop gebruikt 
worden.  

STARTEN 

 Start OpenCities Map Enterprise via het start menu of icoontje op het bureaublad. 

 

 Selecteer de optie No Workspace – No WorkSet.  
Wanneer een bestaande workspace wordt gekozen heeft dit verder geen gevolgen.  

 Open de DGN file TMC Start.dgn.  

 

 Het actieve model is een 2D model met de naam Default. 

IMPORTEREN GML 

De bestuurlijke grenzen 2019 zijn van PDOK (https://www.pdok.nl/downloads/-/article/bestuurlijke-
grenzen) gedownload. 

 

Met de volgende stappen worden de grenzen uit de GML file C:\Tmc\Gml\Gemeentegrenzen.gml 
geïmporteerd. 
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 Open de Imports/Exports dialog via File > Import > Geospatial > GML 
of  
Map > Home > Primary > Imports/Exports. 

 
1. Select het item Import, rechter muisklik > New Import. 
2. Selecteer het item Import, rechter muisklik > Add GML File. 

 In de Add GML File dialog, selecteer de GML file 
C:\Tmc\Gml\Gemeentegrenzen\Gemeentegrenzen.gml. 

 
Een Schema file (XSD) hoeft niet te worden aangegeven. 

 In de Imports/Exports dialog, wordt de symbologie ingesteld, 
zoals level, kleur etc. 

1. Pas de transparency aan. 
2. Pas de vulkleur aan. 
3. Start de import.  

Selecteer Gemeentegrenzen > rechter muisklik > Import. 
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 Alle grenzen worden opgehaald.  
Het te bevragen gebied kan beperkt worden tot een Fence of View met de optie Spatial Area. 

 

 Bekijk de attributen met de Analyze tool (Map > Home > Features > Analyze). 

 

 

Noot: Om vlakken te selecteren d.m.v. van een datapunt in het vlak (i.p.v. op de rand) wijzig 
een Preference setting.  

o Open de Preference dialog (File > User > Preferences). 
o Wijzig de optie Category Input > Locate Interior in Always. 

 

PDOK LOCATIE SERVER 

Via de PDOK locatie server worden op adres gezocht, bv. 
http://geodata.nationaalgeoregister.nl/locatieserver/v3/suggest?wt=xml&q=hofstraat%20110&rows=20 

1. Open de Zoek Adres tool (Drawing > PDOK > PDOK Services > Zoek Adres). 

 

 
2. Vul de postcode in: 1621HX2. 
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3. Klik op Locate. 
Er wordt ingezoomd op de locatie van het gevonden adres. 

4. Optioneel kan de automatisch zoom worden ingesteld. 
Noot: Er zijn drie VBA projecten geladen (Drawing > Utilities > Macros > VBA Manager) 

 

PDOK WMS 

PDOK serveert een groot aantal layers, https://www.pdok.nl/datasets. Onder het kopje Geo Services 
worden de beschikbare URL’s aangegeven voor de verschillende formaten. 

In de Raster Manager wordt een koppeling naar een WMS layer gemaakt. 

 Open de Raster Manager (Drawing > Home > Primary > Raster Manager). 

 
 Open de WMS Map Editor (File > New > WMS …) 

 
 Via Servers, voeg de URL toe, 

https://geodata.nationaalgeoregister.nl/ahn2/wms?request=GetCapabilities&service=wms  
1. Kies de URL. 
2. Kies een een layer. 
3. Kies Add to Map. 
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4. Kies Save and Attach 
Het meta-bestand wordt opgeslagen en gekoppeld. 

 

PDOK WMS SNEL KOPPELEN 

 De meest gebruikte PDOK WMS services zijn beschikbaar in een aparte ribbon, Drawing > 
PDOK WMS. 

 

Met de tools in de button group PDOK WMS Services kan direct een connectie worden gemaakt 
met een PDOK service. 

 Koppel de actuele luchtfoto, top10 enz. 
Noot: Deze tools zijn ook beschikbaar in MicroStation. 

PDOK WFS 

PDOK biedt ook WFS layers aan via datasets. Met deze service kunnen objecten in de DGN file 
geplaatst. 

In de Import/Export dialog wordt een connectie gemaakt met een WFS server met de CBS wijken en 
buurten.. 

 Open de Imports/Exports dialog via File > Import > Geospatial > WFS Server 
of  
Map > Home > Primary > Imports/Exports. 

 Vul de URL in:  
https://geodata.nationaalgeoregister.nl/wijkenbuurten2018/wfs?&request=GetCapabilities&service
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=WFS  

 
 In de Imports tab worden layers getoond. 

o Wijzig de Feature Symbology. 

o Wijzig de Spatial Area van All naar View. 

  

 Start de import.  
Selecteer Import, rechter muisklik > Import. 
De gekozen layers worden geïmporteerd. Features worden met geometrie en attributen in de DGN 
file geplaatst. 
Noot: Wanneer een import nogmaals wordt uitgevoerd, worden de features gedupliceerd. 

Ipv een import, kan een connectie worden gemaakt met een server waarbij een feature slechts één keer 
in de DGN file wordt  geplaatst. 
Maak een connectie met de spoorwegen. 

 Open de Imports/Exports dialog via Home > Primary > WFS Server. 



                    PDOK WFS 

 

 

TMC Summerschool 2019 OpenCities Map en Open Data / PDOK  

6/11/2019 9 Version 1.1 

 

 Vul de URL in: 
https://geodata.nationaalgeoregister.nl/spoorwegen/wfs?request=GetCapabilities&service=wfs  
en accepteer alle layers. 

 Open de Map Connections dialog. 
In Spatial Tools button group, klik op het icoontje rechts onder. 

 

 In de Map Connections dialog wordt de symbology van elke feature ingesteld. 

  

 Selecteer de Query tool om het opvragen van de spoor features te starten.. 
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PDOK WFS SNEL KOPPELEN 

De meest gebruikte PDOK WFS services zijn beschikbaar in een aparte ribbon, Map > PDOK WFS. 

KADASTRALE GRENZEN 

 

 Opvragen van kadastrale grenzen.  
Selecteer de knop BRK Kad Grenzen. 
In het Default model van de actieve DGN file worden de grenzen op verschillende lagen geplaatst 
afhankelijk van de status. 

 Eventueel kan de presentatie worden aangepast in de Level Manager. 

 

KADASTRALE PERCELEN 

 Opvragen van kadastrale percelen, perceel nummers en bijpijling. 
In het Default model van de actieve DGN file worden de percelen en perceelnummers (met 
rotatie) geplaatst. 

1. Maak een connectie met de WFS server. 
Selecteer de knop Connect. 

2. Vraag de percelen op per view of fence. 
Selecteer de knop Query View 1. 

3. Update de perceelnummers en bijpijling. 
Selecteer de knop Update Labels 

4. Update de richting van perceelnummers. 
Selecteer de knop Plaats Perceelnummr 
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BAG 

 Opvragen van panden en verblijfsobjecten. 
In het Default model van de actieve DGN file worden de panden en adressen (met rotatie) 
geplaatst op verschillende lagen geplaatst afhankelijk van de status. 

1. Vraag de percelen op per view of fence. 
Selecteer de knop BAG Query. 
Indien een Connection dialog verschijnt, kies OK. 

2. Maak een rapport van alle adressen in de view of fence. 
 

 

 

Noot: Om de BAG features met succes meerdere keren op te vragen, moet de DGN file aangemaakt 
zijn met de juiste seed file C:\Tmc\Bag VBO Template.dgn. 

 

BGT PUNT OBJECTEN NAAR 3D 

Een 2D DGN file met BGT features kan worden opgewerkt naar een 3D model.  
BGT punt features worden uit een SHP file geïmporteerd en vervolgens worden de 2D punt symbolen 
door een 3D symbool vervangen. 
 
In de gemeente Hoorn worden bomen en ov verlichting naar 3D symbolen omgezet. Afhankelijk van 
de hoogte en type wordt een verschillend symbool met verschillende grootte geplaatst. 
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 In de DGN file C:\Tmc\Tmc Start.dgn, open het 3D model Design3D. 

 
 Navigeer naar de gemeente Hoorn. 

Optioneel: In de Saved Views dialog is al een view Hoorn aanwezig. 

 
 Optioneel: Koppel een reference DGN file C:\Tmc\Hoorn\BGT\BGT.dgn. 

Noot: Koppel de reference met method Coincident World. 

 
 Importeer de SHP files: 

1. C:\Tmc\Hoorn\Ov\openbare_verlichtingPoint.shp en 
2. C:\Tmc\Hoorn\Bomen\v_bomenPoint.shp. 

Noot: I.p.v. SHP files kunnen ook WFS layers gebruikt worden om 3D features te maken. 
 Plaats een fence of maak een selection set van de ov en boom features. 

Noot: Begin eerst met een klein gebied om snel tot een resultaat te komen. 
 Plaats (3D) bomen en (3D) verlichting met de Plaats 3D .. tools.(Map > Convert 3D > BGT 3D). 

Controleer eventuele foutmeldingen in de MS message dialog. 
Op basis van properties als Hoogte en Soort worden bomen en lantaarnpalen geplaatst. 
De Cell bibliotheken in de folder C:\Tmc\Cell\ bevat de gebruikte symbolen. 

 

AHN 

AH3 bestanden kunnen van PDOK worden gedownload en in MicroStation / OpenCities Map getoond 
worden. Uit een AHN3 bestand wordt een hoogtelijnen en hoogte labels gegenereerd. 
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PRESENTEREN 

 In de DGN file C:\Tmc\Tmc Start.dgn, open het 3D model Design3D. 

 Open de Point Clouds dialog. 

 

 Koppel de AHN file C:\Tmc\Hoorn\AHN3\C_19FZ1.pod. 

 
Noot: De LAZ file C_19FZ1.LAZ die van PDOK is gedownload, is geconverteerd naar een POD 
file. 

 De AHN file kan op verschillende manier getoond worden.  
Open de View Attributes dialog, 
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 In section Point Cloud Styles, select Classification & Intensity. 

 
De classificatgies van de pointcloud wordt getoond. 

 De verschillende classificaties kunnen worden aan/uitgezet. 
in de View Attributes dialog, section Point Cloud Styles, kies het puntjes icon om de Point 
Cloud Styles dialog te openen.. 

 

 In Point Cloud Styles dialog, kunnen classificaties worden aan/uitgezet. 

 

AANMAKEN TERREIN MODEL 

Uit een AHN wordt een terreinmodel met hoogtelijnen en hoogte labels gemaakt. 
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Voor een snellere performance is een uitsnede gemaakt uit het AHN bestand m.b.v. de Point Cloud 
Tile Export tool. Hierbij is een filter toegepast voor de classificaties Water en Ground. 

 Ontkoppel het AHN bestand C_19FZ1.pod en koppel de point cloud file 
C:\Tmc\Hoorn\AHN3\C_19FZ1 part grond.pod. 

 

 Van de point cloud wordt een terreinmodel gemaakt. 
Open de Scalable Terrain Model dialog (Reality Modeling > Home > Attach Tools > Scalable 
Terrain Model). 

 

 Een terrein model is reeds gemaakt van de point cloud. Optioneel kunnen breeklijn van bv, sloten 
en wegkanten toe worden gevoegd, 
Koppel C:\Tmc\Hoorn\STM\Hoorn.stm. 
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 In de Scalable Terrain Model dialog, selecteer de STM file. 
In de Properties dialog, wordt de presentatie van de hoogtelijn bepaald. 

 

 Maak van een Scalable Terrain Model een Terrain Model. 
In de Scalable Terrain Model dialog, selecteer de STM file en kies Export STM to TM. 

 

 Het Terrein Model kan met MicroStation tools gebruikt worden. 
Plaats labels met Label Terrain Contours (Drawing > Annotate > Terrain Model > Label). 

 

BGT VLAKKEN 3D 

Met een open source tool 3DFier (beschikbaar via https://github.com/tudelft3d/3dfier) worden BGT 
features mb van een AHN bestand op “3D” gebracht. 
De DGN file C:\Tmc\Delft\Delft 3D.dgn bevat een voorbeeld van het resultaat.  
Uit BGT files en AHN file die van PDOK zijn gedownload, is een 3D model aangemaakt.  
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RESULTAAT 3DFIER 

 Beëindig OpenCities Map Enterprise met File > Exit. 
Kies niet Close en Open geen andere DGN file! 

 Start OpenCities Map Enterprise en open de DGN file C:\Tmc\Delft\Delft 3D.dgn. 
Het model Design3D bevat twee references van OBJ files die met 3DFier.exe zijn gemaakt. 

 Wijzig de Display Style van WireFrame naar Smooth Shadows. 

 
en de Default Lightning is Off. 

 

 De schaduwen worden bepaald door de tijd, plaats en zon. 
Open de Light Manager (Visualization > Home > Light Manager). 

 

 Kies Light Name Solar. 
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 In de Solar Position tab, definieer tijd en plaats.  
De schaduw wordt automatisch aangepast. 

 

 

RUN 3DFIER 

Het tekst bestand ThreeDFier_PandOnly_Hoo.yml (in C:\Tmc\Hoorn) bevat de parameters om 
3DFier uit te voeren. Uit een GML file met de BGT pand gegevens bgt\bgt_pand.gml en een AHN3 
bestand ahn3\C_19FZ1.laz wordt een OBJ file aangemaakt. 

 Open een DOS window. 
 Voer in:  

o Cd C:\Tmc\Hoorn 
o <pad 3DFier>\3dfier ThreeDFier_Hoo.yml --OBJ obj/3dBGTHoorn.obj 

 In de DGN file C:\Tmc\Tmc Start.dgn, open het 3D model Design3D. 

 Bekijk het resultaat door de OBJ file obj/3dPandHoo.obj  als reference te koppelen. 
In de Reference dialog, zet de Presentation op Illustration (de OBJ file) en op Wireframe  
(de BGT file),  
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De conversie moet nog aangepast worden, de hoofdgebouwen ontbreken. 

POSTGRESQL / POSTGIS DATABASE 

PostgreSQL database is een open source database met PostGIS als de spatial extension. 

Geïnstalleerd is de EnterpriseDB Windows 64-bit installer for PostgreSQL 10.5 dmv de EXE file: 
postgresql-10.5-1-windows-x64.exe. 

 

De PostGIS database is gevuld met het commando: 
“C:\Program Files\PostgreSQL\10\bin\psql.exe" -h localhost -U postgres -d postgres -p 5432 -f 
"C:\Tmc\Delft\restore.sql" 

Features kunnen worden geïmporteerd (read-only) of een connectie (read/write) kan worden gemaakt. 

 In de DGN file C:\Tmc\Tmc Start.dgn, open het 3D model Design3D. 

 Open de PostGIS Connect dialog. 

 
 Voer de connection parameters in:  
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o User: Postgres 
o Password: admin  
o Host: localhost  
o Database: postgres 

 
 Haal de layer GeneralSpace op. 

 
 Het resultaat is ook al beschikbaar in het model Design3D Delft. 

 

REALITY MESH ATTACHMENT 

Een voorbeeld van een reality mesh model is meegeleverd in C:\Tmc\Eindhoven\EindhovenDesign 
CE.dgn. 
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In het model worden de BAG panden gebruikt om het 3D object te tonen. 

 BGT files en PDOK BAG panden zijn als references gekoppeld. 

 
In de Reality Mesh dialog, voeg twee classifiers toe (met Type is Level).  
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 Set Margin > 0, bv. 1 of 2. 
Double click to change the Active Classifier.. 

 

 Optioneel: In de Reality Mesh dialog, zet de display aan/uit. 


