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TMC-VNMG Summerschool 2018

Workshop: Templates back to basics 


16-05-2018


Door: 
Tobias Rooijers 
Jeroen van de Wiel 


Oefening 1 Templatebibliotheek 

In deze oefening zal een nieuwe template bibliotheek worden geopend en verkend 

1. Start OpenRoads Designer op.
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2. Maak een nieuwe tekening aan door ‘new file’ te selecteren. Omdat er nu enkel in de template library gewert gaat worden is de seed file niet van belang. Kies een bestandsnaam en een locatie om de tekening op te slaan.
3. Create Template venster openen welke onder de Corridors ribbon is te vinden. 
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4. Selecteer File > Open. 

5. In de verkenner zoek naar de locatie van de geleverde template bibliotheek: Workshop template.itl 

Oefening 2 Verkennen van punt eigenschappen: 

In deze oefening gaan de punt eigenschappen van een bestaand template bekeken worden. 
1. Klap de map Totaal template uit in de Template Library 

2. Dubbel klik op het Toerit totaal template om deze actief te maken en deze te kunnen wijzigen. (Het template wordt weergegeven. Het template bevat drie aspecten; rijbaan, berm en talud (end condition)). 

3. Zoom in op punt VH-RAND-HRR en open nu de punt eigenschappen door dubbel te klikken of door rechtermuisknop op het punt en edit point te selecteren. 

[image: ]De punt eigenschappen bevatten verschillende aspecten zoals naamgeving, Feature definition en relatie tot gekoppelde punten. Onderin zijn de constraints te vinden. Constraints geven de beperkingen aan van het betreffende punt ten opzichte van andere punten. In het voorbeeld links is te zien dat punt VH-RAND-HRR 7,55m horizontaal is gelegen ten opzichte van VH-RAND-HRL (parent) en onder een helling van -2,5% vanaf VH-RAND-HRL (parent). In het voorbeeld zijn beide constraints ten opzichte van het zelfde punt. Dit is niet noodzakelijk. 


Het aantal constraints is gemakkelijk te herkennen aan de kleur van het plus teken welke het punt weer geeft. 
· Rood = volledig beperkt punt door twee constraints 
· Geel = gedeeltelijk beperkt punt door één constraint 
· Groen = onbeperkt punt door geen constraints 
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In de afbeelding hierboven is te zien dat As geen beperkingen heeft. GW-TEEN-HRL heeft één beperking en VH-RAND-HRL heeft twee beperkingen. 
De waarde van de beperking is ook van belang. 
· De afstand is positief als de parent een lagere X of Y waarde heeft als het child. 
· De afstand is negatief als de parent een hogere X of Y waarde heeft als het child. 
· De helling van het component is gebaseerd op de wiskundige helling. 
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Naast de waarde kan er ook een label worden toegekend aan een constraint. Dit zijn parametrische labels. Dit houdt in dat de waardes, waar het label aan is gekoppeld, gemakkelijk aan te passen zijn voor meerdere punten. 




Oefening 3 Aanpassen bestaande template: 

In deze oefening zullen breedtes en hellingen van een punt aangepast worden. Dit zal op twee manieren worden gedaan. De eerste methode is direct door de punt eigenschappen te wijzigen. De tweede methode zal via Parametric Constraint meerdere punten tegelijk wijzigen. 

Direct wijzigen van punt eigenschappen: 

1. Als de Point Properties gesloten zijn, dubbelklik dan op het punt VH-RAND-HRR of rechtermuisknop op het punt en selecteer edit point. 

2. Verander de Horizontal waarde (rijbaan breedte) naar 8 meter. 

3. Klik Apply en zie wat er verandert aan het template 

4. Verander de Slope waarde (afschot) naar -2% (Vergeet niet het procent teken % toe te voegen). 

5. Klik Apply en zie wat er verandert aan het template 

6. Sluit de Point Properties van punt VH-RAND-HRR. 
7. Dubbelklik op het punt VH-RAND-HRR-ON of rechtermuisknop op het punt en selecteer edit point. 

8. Wijzig de Vertical waarde (dikte rijbaan) naar -0,15 meter. 

9. Klik Apply en zie wat er verandert aan het template 

10. Sluit de Point Properties van punt VH-RAND-HRR-ON. 

11. Zoom nu uit zodat het gehele template te zien is. 

De dikte van de verharding is nu enkel voor een punt gewijzigd. Als alle punten voor de onderkant van de verharding gewijzigd moeten worden neemt dit veel tijd in beslag. Hiervoor is de parametric constraint ontwikkeld. Bij de verticale waarde voor de punten is het Label dikte deklaag toegevoegd. Dit label wordt toegevoegd in het Point Properties window. 

[image: ]
Wijzigen van meerdere punteigenschappen (parametric constraint): 

1. Undo de vorige wijziging voor de dikte van de rijbaan. Dit kan door het selecteren van het Undo icoontje onderaan het Create Template window of door Ctrl + Z. 

2. Klik op het Active Template tab aan de linker zijde van het Create Template window. 

3. Klap de Parametric Constraints lijst open en dubbelklik of rechtermuisknop > Edit het label dikte deklaag. 

4. Wijzig de dikte naar 0,15 meter 

5. Klik Ok en zie wat er verandert aan het template 
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Oefening 4 Opbouw nieuw template: 

In deze oefening zal een component voor de deklaag van een rijbaan gemaakt worden. 

Setup van de template opties 

[image: ]1. Open de Dynamic Settings door het selecteren van het icoontje onderaan het Create Template window of door het selecteren Tools > Dynamic Settings. 

2. Defineer de interval opties door bij Step Options X en Step Options Y een waarde van 0,1 in te vullen (doorgaans zal deze interval waarde voldoende zijn voor het werken met templates). 

3. Zorg dat het vakje van Apply Affixes niet aangevinkt staat. 
Hierdoor worden voor en achtervoegsels aangebracht. Dit wordt echter niet behandeld in de workshop. 

Creëer een nieuw template 
1. Klik op de Library tab aan de linker zijde van het Create Template venster. 

2. Rechter muisknop op de Componenten folder en klik New > Template. 

3. Rechter muisknop op het New Template en klik Rename. 

4. Vul als nieuwe template naam Deklaag in. 

5. Een Simple component toevoegen door rechter muisknop in het lege venster te klikken Add New Component > Simple of via Add > Simple (klik het component nog niet in het venster). 

Aan de muis komt nu een balk te hangen en onderaan in het Create Template venster komen lege velden te voorschijn waar Name, Slope Thickness, Width en Feature ingevuld kan worden.
 
6. Vul het volgende in voor de lege velden: Name Deklaag Slope -2,5% (Let op percentage teken) Thickness 0,1 Width 3,5 

7. Klik nu het component met de juiste gegevens op het 0/0 punt van het Create Template venster. (als het component al eerder geplaatst is kan ook met Rechtermuisknop > Change Template Origin het 0/0 punt aangepast worden). 

8. Geef de vier punten nu de juiste benaming met feature en label. VH-RAND-HRL (linker kant verharding) VH-RAND-HRR (rechter kant verharding) VH-RAND-HRL-ON (linker onderkant verharding) VH-RAND-HRR-ON (rechter onderkant verharding)



Oefening 5 Samenvoegen templates: 

In dit onderdeel van de oefening gaat een template samen gesteld worden door middel van verschillende componenten. Deze componenten zijn al gegeven in de template library en hierboven aangemaakt. Het product is de rechterzijde van een rijbaan.
 
1. Rechter muisknop op de map Totaal template in de template library en klik New > Template. 

2. Rechter muisknop op het New Template en klik Rename. 

3. Vul als nieuwe template naam 1x2 dakprofiel rechts in. 

4. Klap de Componenten folder in de Library open. 

5. Klik één keer op het template Deklaag (belangrijk dat maar één keer wordt geklikt, anders wordt het template actief). Het Preview venster in de linker onder hoek geeft een voorbeeld van het Deklaag template. In het Preview venster kan het punt geselecteerd worden waaraan het template geïmporteerd kan worden, dit door op het betreffende punt te klikken 

6. Het template kan nu vanuit de Library of het Preview venster in het actieve template worden gesleept. Laat het Linker bovenpunt op het 0/0 punt vallen. 
7. Voeg nu op dezelfde wijze de componenten Tussenlaag en Onderlaag toe. Het linker boven punt van het toe te voegen template valt op het linker onder punt van het bovenliggende component. Wanneer het component naar het actieve template gesleept wordt, blijft de linker muisknop in gedrukt. Deze wordt losgelaten wanneer het in te voegen component boven het juiste punt hangt. Als dit verkeerd gaat kan met Ctrl-Z de import ongedaan worden gemaakt. Als de Deklaag, Tussenlaag en Onderlaag zijn samengevoegd ziet het er als volgt uit 
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8. Als laatste component dient de berm toegevoegd te worden. Sleep het linker punt van component Buitenberm op het punt VH-RAND-HRR. 
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Oefening 6 Totaal template: 

In de oefening hiervoor is enkel de rechterzijde opgebouwd. De linker zijde kan op dezelfde manier aangemaakt worden, maar dit kan ook automatisch. Door de drag en drop techniek naar een nieuw template. Het product is een totaal template voor een rijbaan in dakprofiel. 

1. Rechter muisknop op de map Totaal template in de template library en klik New > Template. 

2. Rechter muisknop op het New Template en klik Rename. 

3. Vul als nieuwe template naam 1x2 dakprofiel totaal in. 

4. Klap de Totaal template folder in de Library open. 

5. Sleep het hiervoor gemaakte template in het actieve template. Tijdens het slepen (linkermuis knop ingedrukt houden), druk op de rechtermuis knop en er verschijnt een pop up venster. Selecteer hier de Mirror funcie. 

De Mirror functie spiegelt het template. De Reflect functie verwisseld de zijden. 
[image: ]
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6. Sleep nu beide zijden naar het 0/0 punt. 

7. Het samenvoegen van de componenten van de linker en de rechterzijde tot één component wordt gedaan door rechtermuis knop te doen op de plek waar beide componenten elkaar raken (midden van het template) en selecteer Merge Components. Doe dit voor de Deklaag, tussenlaag en onderlaag. 


8. Klik File > Save om het template op te slaan in de template bibliotheek. 

Oefening 7 Testen van totaal template: 

In het Create Template venster kan het gemaakte template getest worden. De berm component welke in het totaal template is verwerkt heeft zogenoemde end conditions. Dit zijn open componenten welke zoeken naar een snijding met het terreinmodel of een ander Surface. 
1. Klik rechts onderin het Create Template venster op de knop Test. Een nieuw venster verschijnt waarin het template wordt weergegeven. 

2. Klik rechts op Draw. Hiermee wordt een theoretische lijn getekend welke is gelinkt aan de muis. 

3. Kijk wat er met het template gebeurd bij verschillende hoogtes de theoretische lijn (Tip verander de Surface Slope). 

4. Sluit het Test End Conditions venster. 


Oefening 8 Van Template naar Corridor: 
In deze opdracht gaat het template gekoppeld worden aan een as. Hiermee wordt een zogenoemd Corridor gecreëerd. 
Voordat de corridor gemaakt kan worden dient een nieuwe tekening gemaakt te worden (DGN) en de as (ALM) en het terreinmodel (DTB) worden ingeladen. 

1. Klik File > New om een nieuw DGN te maken. Let hierbij op dat bij Seed Seed2D - Metric Design.dgngeselecteerd wordt. Deze is te vinden op de geleverde memorystick onder de map Seed. De bestandsnaam dient ingevuld te worden waarna met Openen de nieuwe tekening wordt aangemaakt. De nieuwe tekening is leeg. De as en het terreinmodel worden als Reference ingeladen 
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2. Selecteer onder de Home ribbon Attach tools en vervolgens References.

[image: ]

3. In het pop up venster dient Attach Reference geselecteerd te worden.

[image: ]
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3. Voeg de ALM en het DTB toe als reference. Als de Reference geselecteerd is komt het scherm, weergegeven aan de rechterzijde, naar voren. Selecteer zowel voor ALM en DTB Ok om de reference toe te voegen.
Zorg ervoor dat Orientation op Coincident – World staat. 
Om het corridor aan te laten sluiten op het terreinmodel, dient deze eerst Active te worden gemaakt 


4. Door de rand ( Boundary) van het DTB te selecteren, komen er drie icoontjes naar voren. Door op het middelste icoontje te drukken wordt het terreinmodel Active gemaakt 
[image: ]



5. Om het Corridor aan te maken dient in de onder de ribbon Corridors New Corridor geselecteerd te worden. 

[image: ]

6. Rond de muis komt een balk naar voren waar Locate Corridor Baseline staat aangegeven. Selecteer hiervoor de as. Als de as is geselecteerd komt de volgende balk naar voren bij de muis. Locate Profile-Reset For Active Profile. Kies voor het Active Profile door op de rechtermuisknop te drukken (hiermee word het verticaal alignement van de as gekozen).
[image: ]7. Het Create Template Drop venster komt naar voren. Hierin kunnen de begin en eindmetreringen, het interval en het template worden ingegeven. Selecteer Lock to Start en Lock to End om de templates langs de gehele as te plaatsen. Het interval is vrij in te vullen. Let op hoe kleiner het interval hoe gedetailleerder het Corridor. 

Selecteer voor het Template de gegeven template Toerit totaal of het gemaakte template 1x2 dakprofiel totaal. Wanneer het gehele venster is ingevuld dienen alle opties met de linkermuisknop geaccepteerd te worden. Wanneer dit is doorlopen wordt er langs de as een Corridor gecreëerd. 
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